Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
engine
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
AURA
engine
Commits
168f8797
Commit
168f8797
authored
2 years ago
by
David Trattnig
Browse files
Options
Downloads
Patches
Plain Diff
feat(make): add release target
parent
cffc7c34
No related branches found
No related tags found
No related merge requests found
Pipeline
#2925
passed
2 years ago
Stage: test
Stage: release
Changes
1
Pipelines
2
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
Makefile
+7
-0
7 additions, 0 deletions
Makefile
with
7 additions
and
0 deletions
Makefile
+
7
−
0
View file @
168f8797
...
@@ -14,6 +14,7 @@ help::
...
@@ -14,6 +14,7 @@ help::
@
echo
" db.connect - connect to the database"
@
echo
" db.connect - connect to the database"
@
echo
" log - tail log file"
@
echo
" log - tail log file"
@
echo
" run - start app"
@
echo
" run - start app"
@
echo
" release - tag and push release with current version"
$(
call docker_help
)
$(
call docker_help
)
...
@@ -83,3 +84,9 @@ log::
...
@@ -83,3 +84,9 @@ log::
run
::
run
::
poetry run python3
-m
aura_engine.app
poetry run python3
-m
aura_engine.app
release
::
VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml"
,
"rb"))["tool"]["poetry"]["version"])')
release
::
git tag
$(
VERSION
)
git push origin
$(
VERSION
)
@
echo
"Release '
$(
VERSION
)
' tagged and pushed successfully."
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment