From 168f8797c83eaaa18df90a718357803a7202065f Mon Sep 17 00:00:00 2001
From: David Trattnig <david@subsquare.at>
Date: Wed, 22 Feb 2023 20:41:23 +0100
Subject: [PATCH] feat(make): add release target

---
 Makefile | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/Makefile b/Makefile
index b3480e23..bcf989ba 100644
--- a/Makefile
+++ b/Makefile
@@ -14,6 +14,7 @@ help::
 	@echo "    db.connect      - connect to the database"
 	@echo "    log             - tail log file"
 	@echo "    run             - start app"
+	@echo "    release         - tag and push release with current version"
 	$(call docker_help)
 
 
@@ -83,3 +84,9 @@ log::
 
 run::
 	poetry run python3 -m aura_engine.app
+
+release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
+release::
+	git tag $(VERSION)
+	git push origin $(VERSION)
+	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file
-- 
GitLab