diff --git a/Makefile b/Makefile
index b3480e23e9b5715a2938ce72eed63197426db1fe..bcf989ba572685f79ab50607d793e0f42dd76f04 100644
--- a/Makefile
+++ b/Makefile
@@ -14,6 +14,7 @@ help::
 	@echo "    db.connect      - connect to the database"
 	@echo "    log             - tail log file"
 	@echo "    run             - start app"
+	@echo "    release         - tag and push release with current version"
 	$(call docker_help)
 
 
@@ -83,3 +84,9 @@ log::
 
 run::
 	poetry run python3 -m aura_engine.app
+
+release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
+release::
+	git tag $(VERSION)
+	git push origin $(VERSION)
+	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file