Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
dashboard
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
AURA
dashboard
Commits
c45f2f8a
Commit
c45f2f8a
authored
8 months ago
by
Konrad Mohrfeldt
Browse files
Options
Downloads
Patches
Plain Diff
tests: only mount source files for tests
parent
bcca7f81
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
tests/Dockerfile
+2
-0
2 additions, 0 deletions
tests/Dockerfile
tests/docker-compose.yml
+21
-1
21 additions, 1 deletion
tests/docker-compose.yml
with
23 additions
and
1 deletion
tests/Dockerfile
+
2
−
0
View file @
c45f2f8a
...
@@ -2,3 +2,5 @@ FROM mcr.microsoft.com/playwright:v1.42.1-focal
...
@@ -2,3 +2,5 @@ FROM mcr.microsoft.com/playwright:v1.42.1-focal
RUN
apt update
-y
&&
\
RUN
apt update
-y
&&
\
apt
install
-y
make wait-for-it
&&
\
apt
install
-y
make wait-for-it
&&
\
apt-get clean
-y
apt-get clean
-y
USER
pwuser
RUN
mkdir
/home/pwuser/app
This diff is collapsed.
Click to expand it.
tests/docker-compose.yml
+
21
−
1
View file @
c45f2f8a
...
@@ -128,4 +128,24 @@ services:
...
@@ -128,4 +128,24 @@ services:
wait-for-it -t 0 -h "$TANK_HOST" -p "$TANK_PORT"
wait-for-it -t 0 -h "$TANK_HOST" -p "$TANK_PORT"
make test-local
make test-local
volumes
:
volumes
:
-
../:/home/pwuser/app
-
../public/:/home/pwuser/app/public/
-
../src/:/home/pwuser/app/src/
-
../tests/:/home/pwuser/app/tests/
-
../vitest/:/home/pwuser/app/vitest/
-
../.eslintignore:/home/pwuser/app/.eslintignore
-
../.eslintrc.cjs:/home/pwuser/app/.eslintrc.cjs
-
../.prettierignore:/home/pwuser/app/.prettierignore
-
../.prettierrc.json:/home/pwuser/app/.prettierrc.json
-
../.cspell.json:/home/pwuser/app/.cspell.json
-
../index.html:/home/pwuser/app/index.html
-
../Makefile:/home/pwuser/app/Makefile
-
../oidc_callback.html:/home/pwuser/app/oidc_callback.html
-
../oidc_callback_silentRenew.html:/home/pwuser/app/oidc_callback_silentRenew.html
-
../package.json:/home/pwuser/app/package.json
-
../package-lock.json:/home/pwuser/app/package-lock.json
-
../playwright.config.ts:/home/pwuser/app/playwright.config.ts
-
../postcss.config.cjs:/home/pwuser/app/postcss.config.cjs
-
../tailwind.config.js:/home/pwuser/app/tailwind.config.js
-
../tsconfig.json:/home/pwuser/app/tsconfig.json
-
../vite.config.ts:/home/pwuser/app/vite.config.ts
-
../vitest.config.ts:/home/pwuser/app/vitest.config.ts
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment