Commit 82ae7866 authored by David Trattnig's avatar David Trattnig
Browse files

Chore: Make targets for dependency installation

parent fce97431
......@@ -5,18 +5,39 @@ SPELLING_EXCLUDE_FILE = .codespell-excludes
.PHONY: help
help:
@echo "Supported targets:"
@echo " init.app - init application environment"
@echo " init.dev - init development environment"
@echo " lint - verify code style"
@echo " spelling - check spelling of text"
@echo " style - apply automatic formatting"
@echo " test - run the test suite"
@echo
.PHONY: init.app
init.app:
sudo apt install -y \
python3-wheel \
python3-flask \
python3-flask-sqlalchemy \
python3-http-parser \
python3-psycopg2 \
python3-requests \
python3-sqlalchemy
.PHONY: init.dev
init.dev:
sudo apt install -y
codespell \
black \
python3-flake8 \
python3-flake8-docstrings \
python3-validators \
python3-isort
.PHONY: lint
lint:
python3 -m flake8 .
.PHONY: spelling
spelling:
codespell --exclude-file "$(SPELLING_EXCLUDE_FILE)" $(SPELLING_PATHS)
......
......@@ -46,25 +46,13 @@ If you are developing engine you also might want the projects `steering`, `dashb
Install dependencies:
```shell
apt install -y \
python3-wheel \
python3-flask \
python3-flask-sqlalchemy \
python3-http-parser \
python3-psycopg2 \
python3-requests \
python3-sqlalchemy
make init.app
```
For development install following additional requirements:
```shell
apt install -y
codespell \
black \
python3-flake8 \
python3-flake8-docstrings \
python3-validators
make init.dev
```
Create your base configuration from the sample configuration
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment