From 82ae786661d96c14e7bfa800261898ba405ddb83 Mon Sep 17 00:00:00 2001
From: David Trattnig <david@subsquare.at>
Date: Mon, 25 Jul 2022 15:53:52 +0200
Subject: [PATCH] Chore: Make targets for dependency installation

---
 Makefile                        | 23 ++++++++++++++++++++++-
 docs/bare-metal-installation.md | 16 ++--------------
 2 files changed, 24 insertions(+), 15 deletions(-)

diff --git a/Makefile b/Makefile
index a0925a2a..9ca27572 100644
--- a/Makefile
+++ b/Makefile
@@ -5,18 +5,39 @@ SPELLING_EXCLUDE_FILE = .codespell-excludes
 .PHONY: help
 help:
 	@echo "Supported targets:"
+	@echo "    init.app        - init application environment"
+	@echo "    init.dev        - init development environment"
 	@echo "    lint            - verify code style"
 	@echo "    spelling        - check spelling of text"
 	@echo "    style           - apply automatic formatting"
 	@echo "    test            - run the test suite"
 	@echo
 
+.PHONY: init.app
+init.app:
+	sudo apt install -y \
+		python3-wheel \
+		python3-flask \
+		python3-flask-sqlalchemy \
+		python3-http-parser \
+		python3-psycopg2 \
+		python3-requests \
+		python3-sqlalchemy
+
+.PHONY: init.dev
+init.dev:
+	sudo apt install -y
+		codespell \
+		black \
+		python3-flake8 \
+		python3-flake8-docstrings \
+		python3-validators \
+		python3-isort
 
 .PHONY: lint
 lint:
 	python3 -m flake8 .
 
-
 .PHONY: spelling
 spelling:
 	codespell --exclude-file "$(SPELLING_EXCLUDE_FILE)" $(SPELLING_PATHS)
diff --git a/docs/bare-metal-installation.md b/docs/bare-metal-installation.md
index 18534ca5..a3600899 100644
--- a/docs/bare-metal-installation.md
+++ b/docs/bare-metal-installation.md
@@ -46,25 +46,13 @@ If you are developing engine you also might want the projects `steering`, `dashb
 Install dependencies:
 
 ```shell
-apt install -y \
-      python3-wheel \
-      python3-flask \
-      python3-flask-sqlalchemy \
-      python3-http-parser \
-      python3-psycopg2 \
-      python3-requests \
-      python3-sqlalchemy
+make init.app
 ```
 
 For development install following additional requirements:
 
 ```shell
-apt install -y
-      codespell \
-      black \
-      python3-flake8 \
-      python3-flake8-docstrings \
-      python3-validators
+make init.dev
 ```
 
 Create your base configuration from the sample configuration
-- 
GitLab