Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
steering
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
AURA
steering
Commits
c347fb02
Commit
c347fb02
authored
2 years ago
by
Ernesto Rico Schmidt
Browse files
Options
Downloads
Patches
Plain Diff
Use Poetry, update base Python image
parent
a40eab27
No related branches found
No related tags found
No related merge requests found
Changes
1
Hide whitespace changes
Inline
Side-by-side
Showing
1 changed file
Dockerfile
+7
-6
7 additions, 6 deletions
Dockerfile
with
7 additions
and
6 deletions
Dockerfile
+
7
−
6
View file @
c347fb02
FROM
python:3.
9
-slim-bullseye
AS
base
FROM
python:3.
10
-slim-bullseye
AS
base
ENV
PYTHONDONTWRITEBYTECODE 1
ENV
PYTHONUNBUFFERED=1
ENV
PYTHONUNBUFFERED=1
WORKDIR
/steering
WORKDIR
/steering
COPY
requirements.txt
.
COPY
poetry.lock pyproject.toml
.
/
RUN
apt-get update
&&
apt-get
install
-y
libmagic1 curl graphviz
RUN
apt-get update
&&
apt-get
install
-y
libmagic1 curl graphviz
RUN
pip
install
--upgrade
pip setuptools
RUN
pip
install
poetry
==
1.2.1
RUN
p
ip
install
--no-cache-dir
-r
requirements.txt
RUN
p
oetry
install
EXPOSE
8000
EXPOSE
8000
...
@@ -16,10 +17,10 @@ EXPOSE 8000
...
@@ -16,10 +17,10 @@ EXPOSE 8000
FROM
base
AS
dev
FROM
base
AS
dev
VOLUME
["/steering"]
VOLUME
["/steering"]
CMD
["python", "manage.py", "runserver", "0.0.0.0:8000"
]
CMD
[
"poetry", "run",
"python", "manage.py", "runserver", "0.0.0.0:8000"]
FROM
base
AS
prod
FROM
base
AS
prod
COPY
. .
COPY
. .
CMD
["
sh
", "
-c
", "gunicorn
-b
0.0.0.0:8000
-w
$(nproc)
steering.wsgi"]
CMD
["
poetry
", "
run
", "gunicorn
", "-b", "
0.0.0.0:8000
", "-w", "
$(nproc)
", "
steering.wsgi"]
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment