Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
engine
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
AURA
engine
Commits
8da57f9a
Commit
8da57f9a
authored
2 years ago
by
David Trattnig
Browse files
Options
Downloads
Patches
Plain Diff
refact: read version from pyproject.toml
#116
parent
f93dd044
No related branches found
No related tags found
No related merge requests found
Pipeline
#2365
failed
2 years ago
Stage: test
Stage: release
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
VERSION
+0
-1
0 additions, 1 deletion
VERSION
src/aura_engine/engine.py
+3
-5
3 additions, 5 deletions
src/aura_engine/engine.py
with
3 additions
and
6 deletions
VERSION
deleted
100644 → 0
+
0
−
1
View file @
f93dd044
1.0.0-alpha1-dev
\ No newline at end of file
This diff is collapsed.
Click to expand it.
src/aura_engine/engine.py
+
3
−
5
View file @
8da57f9a
...
@@ -23,11 +23,12 @@ The Engine.
...
@@ -23,11 +23,12 @@ The Engine.
import
json
import
json
import
logging
import
logging
import
os
import
time
import
time
from
contextlib
import
suppress
from
contextlib
import
suppress
from
enum
import
Enum
from
enum
import
Enum
import
pkg_resources
from
aura_engine.base.api
import
LiquidsoapUtil
as
LU
from
aura_engine.base.api
import
LiquidsoapUtil
as
LU
from
aura_engine.base.config
import
AuraConfig
from
aura_engine.base.config
import
AuraConfig
from
aura_engine.base.lang
import
DotDict
from
aura_engine.base.lang
import
DotDict
...
@@ -174,10 +175,7 @@ class Engine:
...
@@ -174,10 +175,7 @@ class Engine:
}
}
"""
"""
ctrl_version
=
None
ctrl_version
=
pkg_resources
.
get_distribution
(
"
aura-engine
"
).
version
with
open
(
os
.
path
.
join
(
""
,
"
VERSION
"
))
as
version_file
:
ctrl_version
=
version_file
.
read
().
strip
()
versions
=
self
.
playout
.
get_version
()
versions
=
self
.
playout
.
get_version
()
versions
=
DotDict
(
json
.
loads
(
versions
))
versions
=
DotDict
(
json
.
loads
(
versions
))
self
.
config
.
set
(
"
version_control
"
,
ctrl_version
)
self
.
config
.
set
(
"
version_control
"
,
ctrl_version
)
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment