Commit 5303466a authored by david's avatar david
Browse files

Slim repo and replace MariaDB with PostgreSQL. #73

parent 0dc3aa77
Pipeline #994 passed with stage
in 2 minutes and 30 seconds
......@@ -7,18 +7,17 @@ LABEL maintainer="David Trattnig <david.trattnig@subsquare.at>"
RUN apt-get update && apt-get -y install \
apt-utils \
build-essential \
default-libmysqlclient-dev \
libmariadbclient-dev
build-essential
# Setup Engine
RUN mkdir -p /srv
RUN mkdir -p /srv/src
RUN mkdir -p /srv/config
RUN /usr/local/bin/python -m pip install --upgrade pip
COPY src /srv/src
COPY requirements.txt /srv
COPY contrib/postgresql-requirements.txt /srv
COPY meta.py /srv
COPY run.sh /srv
COPY run.py /srv
......@@ -26,7 +25,7 @@ COPY run.py /srv
WORKDIR /srv
RUN pip3 install -r requirements.txt
RUN pip3 install -r postgresql-requirements.txt
VOLUME ["/srv/socket", "/srv/logs", "/var/audio/source", "/var/audio/playlist"]
# Start the Engine
......
......@@ -2,6 +2,5 @@ requests==2.24.0
sqlalchemy==1.3.17
Flask==1.1.2
Flask_SQLAlchemy==2.4.3
mysqlclient==1.3.12
validators==0.12.1
http-parser==0.9.0
\ No newline at end of file
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment