Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
engine-api
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
AURA
engine-api
Commits
07560f75
Commit
07560f75
authored
2 years ago
by
David Trattnig
Browse files
Options
Downloads
Patches
Plain Diff
feat: run.gunicorn target for make
parent
46963c85
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
Dockerfile
+1
-1
1 addition, 1 deletion
Dockerfile
Makefile
+9
-1
9 additions, 1 deletion
Makefile
sample.docker.env
+3
-1
3 additions, 1 deletion
sample.docker.env
with
13 additions
and
3 deletions
Dockerfile
+
1
−
1
View file @
07560f75
...
...
@@ -43,4 +43,4 @@ RUN set -e \
# Start Service
EXPOSE
8008
ENTRYPOINT
["make"]
CMD
["run"]
CMD
["run
.gunicorn
"]
This diff is collapsed.
Click to expand it.
Makefile
+
9
−
1
View file @
07560f75
...
...
@@ -10,11 +10,14 @@ help::
@
echo
" test - run test suite"
@
echo
" log - tail log file"
@
echo
" run - start app"
@
echo
" run.gunicorn - start app with gunicorn"
$(
call docker_help
)
# Settings
AURA_ENGINE_API_HOST
?=
127.0.0.1
AURA_ENGINE_API_PORT
?=
8008
AURA_ENGINE_API_CONFIG
:=
${
CURDIR
}
/config/engine-api.docker.ini
AURA_LOGS
:=
${
CURDIR
}
/logs
...
...
@@ -33,7 +36,8 @@ DOCKER_RUN = @docker run \
init.app
::
pyproject.toml
poetry
install
cp
-n
config/sample.engine.ini config/engine.ini
cp
-n
config/sample.engine-api.ini config/engine-api.ini
cp
-n
config/sample/gunicorn/sample-production.gunicorn.conf.py config/gunicorn.conf.py
init.dev
::
pyproject.toml
poetry
install
--with
dev
...
...
@@ -60,3 +64,7 @@ log::
run
::
poetry run python3
-m
aura_engine_api.app
run.gunicorn
::
poetry run gunicorn
-c
config/gunicorn.conf.py aura_engine_api.app:app
\
--bind
$(
AURA_ENGINE_API_HOST
)
:
$(
AURA_ENGINE_API_PORT
)
\ No newline at end of file
This diff is collapsed.
Click to expand it.
sample.env
→
sample.
docker.
env
+
3
−
1
View file @
07560f75
TZ=Europe/Vienna
AURA_ENGINE_API_LOG_LEVEL=info
AURA_ENGINE_API_DB_HOST=localhost
AURA_ENGINE_API_HOST=0.0.0.0
AURA_ENGINE_API_PORT=8008
AURA_ENGINE_API_DB_HOST=127.0.0.1
AURA_ENGINE_API_DB_NAME=aura_engine_api
AURA_ENGINE_API_DB_USER=aura_engine_api
AURA_ENGINE_API_DB_PASS=1234
\ No newline at end of file
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment