Commit d94baec5 authored by david's avatar david
Browse files

Change virtualenv to venv.

parent 784a29c5
...@@ -4,9 +4,8 @@ stages: ...@@ -4,9 +4,8 @@ stages:
- test - test
before_script: before_script:
- apt-get -qq update - apt-get -qq update
- apt-get install -y python3-virtualenv virtualenv - python3.8 -m venv python
- /usr/bin/virtualenv python
- . python/bin/activate - . python/bin/activate
- pip3 install -r requirements.txt - pip3 install -r requirements.txt
- cp config/sample-production.engine.ini config/engine.ini - cp config/sample-production.engine.ini config/engine.ini
......
...@@ -44,10 +44,10 @@ If you are developing engine you also might want the projects `steering`, `dashb ...@@ -44,10 +44,10 @@ If you are developing engine you also might want the projects `steering`, `dashb
## Preparation ## Preparation
In case of an development environment, create a virtual env for your Python dependencies: In case of an development environment, create a virtual environment for your Python dependencies:
```shell ```shell
virtualenv -p python3.8 python python3.8 -m venv python
``` ```
No worries, the resulting `python` directory is excluded from the git respostory. No worries, the resulting `python` directory is excluded from the git respostory.
......
...@@ -62,7 +62,7 @@ The following steps espect you having done the bases configuration and set up a ...@@ -62,7 +62,7 @@ The following steps espect you having done the bases configuration and set up a
If you don't have already, you'll need to create an virtual environment: If you don't have already, you'll need to create an virtual environment:
```shell ```shell
~/code/aura/engine$ virtualenv -p python3.8 python ~/code/aura/engine$ python3.8 -m venv python
``` ```
Then you can start the engine. The following command includes the activation of your virtual environment, which you have created during the installation step (`source python/bin/activate`): Then you can start the engine. The following command includes the activation of your virtual environment, which you have created during the installation step (`source python/bin/activate`):
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment