diff --git a/Makefile b/Makefile
index de806b586e16f32db817c0e02142fe753c85e31b..0e82f89d46a67467dc22d624955dcbc251747080 100644
--- a/Makefile
+++ b/Makefile
@@ -35,9 +35,12 @@ loaddata:
 removestaleimages:
 	$(POETRY_RUN_MANAGE) removestaleimages
 
-run.dev: migrate
+run.dev: dev.install migrate
 	$(POETRY_RUN_MANAGE) runserver 0.0.0.0:8000
 
+dev.install:
+	$(POETRY) install --no-root
+
 run.prod: migrate
 	$(POETRY_RUN) gunicorn --bind 0.0.0.0:8000 --workers `nproc` steering.wsgi