From ebc8748c5df85ad3fa03342f7c3436fcdc4dfbb9 Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Mon, 22 Apr 2024 17:35:51 -0400
Subject: [PATCH] feat: add lint & format targets

---
 Makefile | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/Makefile b/Makefile
index 9f2b348a..ea101b21 100644
--- a/Makefile
+++ b/Makefile
@@ -67,5 +67,12 @@ run.prod: migrate collectstatic
 run.debug: migrate
 	DEBUG=1 $(POETRY_RUN_MANAGE) runserver_plus 0.0.0.0:8000
 
+lint:
+	poetry run flake8 program steering
+
+format:
+	poetry run isort program steering
+	poetry run black program steering
+
 test:
 	poetry run pytest --cov
-- 
GitLab