From e9a8453abd85422b3b7b0772200b3cb37c766ffc Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Wed, 6 Sep 2023 21:57:22 -0400
Subject: [PATCH] test: add host and show test fixtures

add loaddata.test make target
---
 Makefile                |  3 +++
 fixtures/test/host.json | 16 ++++++++++++++++
 fixtures/test/show.json | 33 +++++++++++++++++++++++++++++++++
 3 files changed, 52 insertions(+)
 create mode 100644 fixtures/test/host.json
 create mode 100644 fixtures/test/show.json

diff --git a/Makefile b/Makefile
index e5151e9e..307b3340 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,9 @@ loaddata.sample:
 loaddata.custom:
 	$(POETRY_RUN_MANAGE) loaddata fixtures/custom/*.json
 
+loaddata.test:
+	$(POETRY_RUN_MANAGE) loaddata fixtures/test/*.json
+
 removestaleimages:
 	$(POETRY_RUN_MANAGE) removestaleimages
 
diff --git a/fixtures/test/host.json b/fixtures/test/host.json
new file mode 100644
index 00000000..0ae5021a
--- /dev/null
+++ b/fixtures/test/host.json
@@ -0,0 +1,16 @@
+[
+  {
+    "model": "program.host",
+    "pk": 1,
+    "fields": {
+      "name": "Musikredaktion",
+      "is_active": true,
+      "email": "",
+      "biography": "",
+      "image": null,
+      "created_at": "2000-06-01 00:00Z",
+      "created_by": "loaddata"
+    }
+  }
+]
+
diff --git a/fixtures/test/show.json b/fixtures/test/show.json
new file mode 100644
index 00000000..2a138c8c
--- /dev/null
+++ b/fixtures/test/show.json
@@ -0,0 +1,33 @@
+[
+  {
+    "model": "program.show",
+    "pk": 1,
+    "fields": {
+      "predecessor": null,
+      "type": 3,
+      "funding_category": 1,
+      "name": "Musikprogramm",
+      "slug": "musikprogramm",
+      "image": null,
+      "logo": null,
+      "short_description": "Unmoderiertes Musikprogramm",
+      "description": "Unmoderiertes Musikprogramm",
+      "email": "musikredaktion@helsinki.at",
+      "cba_series_id": null,
+      "default_playlist_id": null,
+      "is_active": true,
+      "is_public": false,
+      "hosts": [
+        1
+      ],
+      "owners": [],
+      "language": [],
+      "category": [],
+      "topic": [],
+      "music_focus": [],
+      "created_at": "2000-06-01 00:00Z",
+      "created_by": "loaddata"
+    }
+  }
+]
+
-- 
GitLab