diff --git a/poetry.lock b/poetry.lock
index 6d1dfe7d24cb086793d9159f7f014becf01c9c1b..f3bb4627773d6299ad08bda68577a8aca2ca2126 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -1202,13 +1202,13 @@ dev = ["argcomplete", "attrs (>=19.2)", "hypothesis (>=3.56)", "mock", "pygments
 
 [[package]]
 name = "pytest-cov"
-version = "4.1.0"
+version = "5.0.0"
 description = "Pytest plugin for measuring coverage."
 optional = false
-python-versions = ">=3.7"
+python-versions = ">=3.8"
 files = [
-    {file = "pytest-cov-4.1.0.tar.gz", hash = "sha256:3904b13dfbfec47f003b8e77fd5b589cd11904a21ddf1ab38a64f204d6a10ef6"},
-    {file = "pytest_cov-4.1.0-py3-none-any.whl", hash = "sha256:6ba70b9e97e69fcc3fb45bfeab2d0a138fb65c4d0d6a41ef33983ad114be8c3a"},
+    {file = "pytest-cov-5.0.0.tar.gz", hash = "sha256:5837b58e9f6ebd335b0f8060eecce69b662415b16dc503883a02f45dfeb14857"},
+    {file = "pytest_cov-5.0.0-py3-none-any.whl", hash = "sha256:4f0764a1219df53214206bf1feea4633c3b558a2925c8b59f144f682861ce652"},
 ]
 
 [package.dependencies]
@@ -1216,7 +1216,7 @@ coverage = {version = ">=5.2.1", extras = ["toml"]}
 pytest = ">=4.6"
 
 [package.extras]
-testing = ["fields", "hunter", "process-tests", "pytest-xdist", "six", "virtualenv"]
+testing = ["fields", "hunter", "process-tests", "pytest-xdist", "virtualenv"]
 
 [[package]]
 name = "pytest-django"
@@ -1666,4 +1666,4 @@ tests = ["build", "coverage", "mypy", "ruff", "wheel"]
 [metadata]
 lock-version = "2.0"
 python-versions = "^3.11"
-content-hash = "3374a45be05cc84b19764a5d521d009410f07b93c956cd16276ebac0c592ea0e"
+content-hash = "8ab94677c4f7aa2e623b32b384424c85adc08abf010d6c80aac4401dde07c47c"
diff --git a/pyproject.toml b/pyproject.toml
index 28b345799aa42a063678a959a0793206f69a6cfa..187838575e5fa56d0007eaf16f37ab21988ba1e0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -48,7 +48,7 @@ yq = "^3.4.1"
 [tool.poetry.group.test.dependencies]
 coverage = "^7.4.3"
 pytest = "^8.0.2"
-pytest-cov = "^4.1.0"
+pytest-cov = "^5.0.0"
 pytest-django = "^4.5.2"
 pytest-factoryboy = "^2.5.1"