diff --git a/Makefile b/Makefile
index 2b5658f1fd0460b520f993085d9acac25afcbb42..43563b30520e8aff1545011dcce8a81bf879e22e 100644
--- a/Makefile
+++ b/Makefile
@@ -55,9 +55,3 @@ run.prod: migrate collectstatic
 
 run.debug: migrate
 	DEBUG=1 $(POETRY_RUN_MANAGE) runserver_plus 0.0.0.0:8000
-
-release: VERSION := `$(POETRY_RUN) python -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])'`
-release:
-	git tag ${VERSION}
-	git push origin ${VERSION}
-	@echo "Release '${VERSION}' tagged and pushed successfully."