From 5f3a9670a2c586eda2c04d77b856bcb163827e07 Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Mon, 22 Apr 2024 17:41:18 -0400
Subject: [PATCH] feat: add init.ev target

---
 Makefile | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/Makefile b/Makefile
index ea101b21..905c1e85 100644
--- a/Makefile
+++ b/Makefile
@@ -67,6 +67,11 @@ run.prod: migrate collectstatic
 run.debug: migrate
 	DEBUG=1 $(POETRY_RUN_MANAGE) runserver_plus 0.0.0.0:8000
 
+init.dev: pyproject.toml
+	poetry install --with dev
+	poetry run pre-commit autoupdate
+	poetry run pre-commit install
+
 lint:
 	poetry run flake8 program steering
 
-- 
GitLab