From 57880969499b8bf6864c05a0602cd50eae363824 Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Mon, 22 Jul 2024 16:59:56 -0400
Subject: [PATCH] build: update Poetry dependency: drf-jsonschema-serializer

---
 poetry.lock    | 14 +++++++-------
 pyproject.toml |  2 +-
 2 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/poetry.lock b/poetry.lock
index 2baeb62f..3a53c780 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -456,17 +456,17 @@ files = [
 
 [[package]]
 name = "drf-jsonschema-serializer"
-version = "2.0.0"
+version = "3.0.0"
 description = "JSON Schema support for Django REST Framework"
 optional = false
-python-versions = "*"
+python-versions = ">=3.10"
 files = [
-    {file = "drf-jsonschema-serializer-2.0.0.tar.gz", hash = "sha256:bfeea9f2e49f6f14d12ae5a55680657abb70066615739682351589cda67c3f4f"},
-    {file = "drf_jsonschema_serializer-2.0.0-py3-none-any.whl", hash = "sha256:02b4e4f19d680b0565a4231f1cba29371c01af0e1682944f1e2d1093bbd07d86"},
+    {file = "drf_jsonschema_serializer-3.0.0-py3-none-any.whl", hash = "sha256:d0e5cce095a5638b0bb7867aa060ed59ab9eed2f54ba5058dd9b483c9c887ed5"},
+    {file = "drf_jsonschema_serializer-3.0.0.tar.gz", hash = "sha256:8a42c6079225f789cd55321897073b576d15db3406d008e92f44febb017a232a"},
 ]
 
 [package.dependencies]
-django = ">=3.2"
+django = ">=4.2"
 djangorestframework = ">=3.13"
 jsonschema = ">=4.0.0"
 
@@ -474,7 +474,7 @@ jsonschema = ">=4.0.0"
 all-format-validators = ["fqdn", "idna", "isoduration", "jsonpointer", "rfc3339-validator", "rfc3987", "uri-template", "webcolors"]
 coverage = ["pytest-cov"]
 docs = ["sphinx", "sphinx-rtd-theme"]
-release = ["bump2version", "twine"]
+release = ["bump-my-version", "twine"]
 tests = ["black", "django-stubs[compatible-mypy]", "djangorestframework-stubs[compatible-mypy]", "flake8", "fqdn", "idna", "isoduration", "isort", "jsonpointer", "mypy", "pytest", "pytest-django", "rfc3339-validator", "rfc3987", "tox", "types-jsonschema", "uri-template", "webcolors"]
 
 [[package]]
@@ -1665,4 +1665,4 @@ tests = ["build", "coverage", "mypy", "ruff", "wheel"]
 [metadata]
 lock-version = "2.0"
 python-versions = "^3.11"
-content-hash = "31d4a35c2c30f06136f8cccdd8e425fcaec59b9eefdeec45fc46a848b375bb0f"
+content-hash = "e482ee4cba4afee44c053e5a8217585bfd9223891821320947b4f8d5724aeaeb"
diff --git a/pyproject.toml b/pyproject.toml
index 1ca4ab1a..323fa9f3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,7 +25,7 @@ django-oidc-provider = "^0.8.0"
 djangorestframework = "^3.14.0"
 djangorestframework-camel-case = "^1.4.2"
 django-versatileimagefield = "^3.0"
-drf-jsonschema-serializer = "^2.0.0"
+drf-jsonschema-serializer = "^3.0.0"
 drf-spectacular = "^0.27.1"
 gunicorn = "^21.2.0"
 jsonschema = "^4.22.0"
-- 
GitLab