From 3e6641f2f32bef12c266e92631c00a5b2eaac221 Mon Sep 17 00:00:00 2001
From: Loxbie <ole@freirad.at>
Date: Thu, 22 Feb 2024 13:21:22 +0100
Subject: [PATCH] Fix: add missing admin directory, aura#308

---
 Dockerfile | 24 ++++++++++++------------
 1 file changed, 12 insertions(+), 12 deletions(-)

diff --git a/Dockerfile b/Dockerfile
index 2e70ed7d..c07800b3 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -12,13 +12,13 @@ WORKDIR /app
 COPY poetry.lock pyproject.toml /app/
 
 RUN apt-get update && \
-  apt-get install --yes --no-install-recommends curl gcc graphviz ldap-utils libldap2-dev \
+    apt-get install --yes --no-install-recommends curl gcc graphviz ldap-utils libldap2-dev \
     libmagic1 libsasl2-dev make && \
-  python -m venv ${POETRY_HOME} && \
-  pip install --no-cache-dir poetry==1.7.1 && \
-  poetry install && \
-  apt-get clean && \
-  rm -rf /var/lib/apt/lists/*
+    python -m venv ${POETRY_HOME} && \
+    pip install --no-cache-dir poetry==1.7.1 && \
+    poetry install && \
+    apt-get clean && \
+    rm -rf /var/lib/apt/lists/*
 
 EXPOSE 8000
 
@@ -36,12 +36,12 @@ FROM base AS prod
 COPY . .
 
 RUN adduser --home /app --no-create-home --system --uid ${AURA_UID} --group app && \
-  # static and site_media are named volumes which we use across multiple
-  # containers. We therefore create them here and set the permissions right away
-  # since named volumes otherwise create these directories themself as the root
-  # user.
-  mkdir -p /app/{logs,static,site_media} && \
-  chown -R app:app /app
+    # static and site_media are named volumes which we use across multiple
+    # containers. We therefore create them here and set the permissions right away
+    # since named volumes otherwise create these directories themself as the root
+    # user.
+    mkdir -p /app/{logs,static/admin,site_media} && \
+    chown -R app:app /app
 
 USER app
 
-- 
GitLab