From 2977b14358dab5bf3bffb3645e061ad3b9a78c1d Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Tue, 17 Sep 2024 12:26:46 -0400
Subject: [PATCH] feat: add test_settings and use them to run the tests

---
 pyproject.toml            | 2 +-
 steering/test_settings.py | 3 +++
 2 files changed, 4 insertions(+), 1 deletion(-)
 create mode 100644 steering/test_settings.py

diff --git a/pyproject.toml b/pyproject.toml
index b3dcfa58..26969a56 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -54,7 +54,7 @@ pytest-django = "^4.5.2"
 pytest-factoryboy = "^2.5.1"
 
 [tool.pytest.ini_options]
-DJANGO_SETTINGS_MODULE = "steering.settings"
+DJANGO_SETTINGS_MODULE = "steering.test_settings"
 django_debug_mode = true
 filterwarnings = [
     "ignore::DeprecationWarning",
diff --git a/steering/test_settings.py b/steering/test_settings.py
new file mode 100644
index 00000000..277951d4
--- /dev/null
+++ b/steering/test_settings.py
@@ -0,0 +1,3 @@
+from steering.settings import *  # noqa
+
+OPERATION_MODE = "tests"
-- 
GitLab