From 0e8077cd4e137803704d5ef2fe1691efb40c25e7 Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Tue, 23 Apr 2024 22:36:20 -0400
Subject: [PATCH] build: replace make with entrypoint.sh

---
 Dockerfile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/Dockerfile b/Dockerfile
index 7285f283..014ddf0d 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -13,7 +13,7 @@ COPY poetry.lock pyproject.toml /app/
 
 RUN apt-get update && \
     apt-get install --yes --no-install-recommends curl gcc graphviz ldap-utils libldap2-dev \
-    libmagic1 libsasl2-dev make && \
+    libmagic1 libsasl2-dev && \
     python -m venv ${POETRY_HOME} && \
     pip install --no-cache-dir poetry==1.8.1 && \
     poetry install && \
@@ -41,6 +41,7 @@ RUN adduser --home /app --no-create-home --system --uid ${AURA_UID} --group app
     # since named volumes otherwise create these directories themself as the root
     # user.
     mkdir -p /app/site_media /app/static /app/logs && \
+    chmod +x /app/entrypoint.sh && \
     chown -R app:app /app
 
 USER app
@@ -48,4 +49,4 @@ USER app
 # run with gunicorn
 CMD ["run.prod"]
 
-ENTRYPOINT ["make"]
+ENTRYPOINT ["/app/entrypoint.sh"]
-- 
GitLab