From 0270baabd45740a0a4fe89ae9b46d5d168096211 Mon Sep 17 00:00:00 2001
From: Ernesto Rico Schmidt <ernesto@helsinki.at>
Date: Mon, 22 Jul 2024 17:06:38 -0400
Subject: [PATCH] build: add Poetry dependency: dj-database-url

---
 poetry.lock    | 17 ++++++++++++++++-
 pyproject.toml |  1 +
 2 files changed, 17 insertions(+), 1 deletion(-)

diff --git a/poetry.lock b/poetry.lock
index f3bb4627..8247e040 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -312,6 +312,21 @@ files = [
     {file = "distlib-0.3.8.tar.gz", hash = "sha256:1530ea13e350031b6312d8580ddb6b27a104275a31106523b8f123787f494f64"},
 ]
 
+[[package]]
+name = "dj-database-url"
+version = "2.2.0"
+description = "Use Database URLs in your Django Application."
+optional = false
+python-versions = "*"
+files = [
+    {file = "dj_database_url-2.2.0-py3-none-any.whl", hash = "sha256:3e792567b0aa9a4884860af05fe2aa4968071ad351e033b6db632f97ac6db9de"},
+    {file = "dj_database_url-2.2.0.tar.gz", hash = "sha256:9f9b05058ddf888f1e6f840048b8d705ff9395e3b52a07165daa3d8b9360551b"},
+]
+
+[package.dependencies]
+Django = ">=3.2"
+typing_extensions = ">=3.10.0.0"
+
 [[package]]
 name = "django"
 version = "4.2.14"
@@ -1666,4 +1681,4 @@ tests = ["build", "coverage", "mypy", "ruff", "wheel"]
 [metadata]
 lock-version = "2.0"
 python-versions = "^3.11"
-content-hash = "8ab94677c4f7aa2e623b32b384424c85adc08abf010d6c80aac4401dde07c47c"
+content-hash = "99d1892677369108fe4291a68b56b6b82411b35beb6466c84a5b560493e6163d"
diff --git a/pyproject.toml b/pyproject.toml
index 18783857..18504ae9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -25,6 +25,7 @@ django-oidc-provider = "^0.8.0"
 djangorestframework = "^3.14.0"
 djangorestframework-camel-case = "^1.4.2"
 django-versatileimagefield = "^3.0"
+dj-database-url = "^2.2.0"
 drf-jsonschema-serializer = "^3.0.0"
 drf-spectacular = "^0.27.1"
 gunicorn = "^22.0.0"
-- 
GitLab