From 98db4220f4a7b333e825842e54c61108eedd6a72 Mon Sep 17 00:00:00 2001
From: David Trattnig <david@subsquare.at>
Date: Sun, 25 Jun 2023 12:27:13 +0200
Subject: [PATCH] fix(make): eval version at exec time

---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index c8525d45..affdadf6 100644
--- a/Makefile
+++ b/Makefile
@@ -104,8 +104,8 @@ log::
 run::
 	poetry run python3 -m aura_engine.app
 
-release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
 release::
+	$(eval VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])'))
 	git tag $(VERSION)
 	git push origin $(VERSION)
 	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file
-- 
GitLab