diff --git a/Makefile b/Makefile
index c8525d456bfcfb7202f0b1714c7f31d8387326ad..affdadf62a326828ce9d02586e5609cc5ead538c 100644
--- a/Makefile
+++ b/Makefile
@@ -104,8 +104,8 @@ log::
 run::
 	poetry run python3 -m aura_engine.app
 
-release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
 release::
+	$(eval VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])'))
 	git tag $(VERSION)
 	git push origin $(VERSION)
 	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file