diff --git a/pyproject.toml b/pyproject.toml
index e88d3a3dbf9c79378daadbb0ed85eda6f399e665..11037440a39d603d5e3c6790588d58f4f0c549fc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,16 +1,6 @@
 [project]
 name = "aura-engine"
-description = "AURA Engine scheduling and playout control."
-homepage = "https://aura.radio/"
-repository = "https://gitlab.servus.at/aura/engine"
-authors = [
-    "David Trattnig <david@subsquare.at>",
-    "Gottfried Gaisbauer <gogo@servus.at>",
-]
-readme = "README.md"
 requires-python = "^3.9"
-keywords = ["radio", "scheduling", "audio"]
-license = { text = "AGPL 3" }
 
 [tool.black]
 line-length = 99
@@ -27,10 +17,24 @@ pythonpath = ["src"]
 [tool.poetry]
 name = "aura-engine"
 version = "1.0.0-alpha0"
-description = ""
-authors = ["David Trattnig <david@subsquare.at>"]
-license = "AGPL 3"
+description = "AURA Engine scheduling and playout control."
+license = "AGPL-2.0-or-later"
+authors = [
+    "David Trattnig <david@subsquare.at>",
+    "Gottfried Gaisbauer <gogo@servus.at>",
+]
+maintainers = ["David Trattnig <david@subsquare.at>"]
 readme = "README.md"
+homepage = "https://aura.radio/"
+repository = "https://gitlab.servus.at/aura/engine"
+documentation = "https://docs.aura.radio/"
+keywords = ["radio", "scheduling", "audio", "playout"]
+classifiers = [
+    "Topic :: Multimedia :: Sound/Audio",
+    "Topic :: Multimedia :: Sound/Audio :: Mixers",
+    "Topic :: Multimedia :: Sound/Audio :: Players",
+]
+
 packages = [{ include = "aura_engine", from = "src" }]
 
 [tool.poetry.dependencies]