Commit 0332deed authored by david's avatar david
Browse files

Python 3.8 as a minimum requirement. #61

parent 9d38e17b
Pipeline #900 passed with stage
in 4 minutes and 11 seconds
image: python:3.7 image: python:3.8
stages: stages:
- test - test
...@@ -9,13 +9,6 @@ before_script: ...@@ -9,13 +9,6 @@ before_script:
- apt-get install -y python3-virtualenv virtualenv opam libev4 libev-dev libsndfile1 quelcom # mariadb-server libmariadbclient-dev - apt-get install -y python3-virtualenv virtualenv opam libev4 libev-dev libsndfile1 quelcom # mariadb-server libmariadbclient-dev
- /usr/bin/virtualenv venv - /usr/bin/virtualenv venv
- . venv/bin/activate - . venv/bin/activate
# - opam init --disable-sandboxing -y
# - opam switch create 4.08.0
# - opam update -y
# - opam install depext -y
# - opam depext taglib mad lame vorbis flac opus cry samplerate pulseaudio bjack alsa ssl liquidsoap -y
# - opam install taglib mad lame vorbis flac opus cry samplerate pulseaudio bjack alsa ssl liquidsoap -y
# - eval $(opam env)
- python3 -V - python3 -V
- pip3 install -r requirements.txt - pip3 install -r requirements.txt
- mkdir /etc/aura - mkdir /etc/aura
......
...@@ -17,7 +17,7 @@ ...@@ -17,7 +17,7 @@
Aura Engine runs on any modern Debian-based OS. It requires at least Aura Engine runs on any modern Debian-based OS. It requires at least
- `Python 3.7` or `Python 3.8` - `Python 3.8+`
- `git` - `git`
Additionally you'll need these system packages: Additionally you'll need these system packages:
......
...@@ -20,7 +20,7 @@ ...@@ -20,7 +20,7 @@
Aura Engine runs on any modern Debian-based OS. It requires at least Aura Engine runs on any modern Debian-based OS. It requires at least
- `Python 3.7` or `Python 3.8` - `Python 3.8+`
- `git` - `git`
Additionally you'll need these system packages below. Additionally you'll need these system packages below.
......
...@@ -15,12 +15,12 @@ fi ...@@ -15,12 +15,12 @@ fi
# Find the correct Python version (3.7 or 3.8) # Find the correct Python version (3.7 or 3.8)
if hash python3.8 2>/dev/null; then if hash python3.9 2>/dev/null; then
PYTHON_EXEC="python3.9"
echo "[ Using Python 3.9 ]"
else
PYTHON_EXEC="python3.8" PYTHON_EXEC="python3.8"
echo "[ Using Python 3.8 ]" echo "[ Using Python 3.8 ]"
else
PYTHON_EXEC="python3.7"
echo "[ Using Python 3.7 ]"
fi fi
# Development and Production # Development and Production
......
#!/bin/sh #!/bin/sh
''''which python3.8 >/dev/null 2>&1 && exec python3.8 "$0" "$@" # ''' ''''which python3.9 >/dev/null 2>&1 && exec python3.9 "$0" "$@" # '''
''''which python3.7 >/dev/null 2>&1 && exec python3.7 "$0" "$@" # ''' ''''which python3.8 >/dev/null 2>&1 && exec python3.8 "$0" "$@" # '''
''''exec echo "Error: Snaaakey Python, where are you?" # ''' ''''exec echo "Error: Snaaakey Python, where are you?" # '''
# #
......
...@@ -32,14 +32,14 @@ echo "[ Run mode=$mode ]" ...@@ -32,14 +32,14 @@ echo "[ Run mode=$mode ]"
echo "[ Docker=$docker ]" echo "[ Docker=$docker ]"
# Find the correct Python version (3.7 or 3.8) # Find the correct Python version (3.8 or 3.9)
if hash python3.8 2>/dev/null; then if hash python3.9 2>/dev/null; then
PYTHON_EXEC="python3.9"
echo "[ Using Python 3.9 ]"
else
PYTHON_EXEC="python3.8" PYTHON_EXEC="python3.8"
echo "[ Using Python 3.8 ]" echo "[ Using Python 3.8 ]"
else
PYTHON_EXEC="python3.7"
echo "[ Using Python 3.7 ]"
fi fi
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment