From b014c69ca6f6992cd5c5c2dc680a4a796efae8c6 Mon Sep 17 00:00:00 2001
From: David Trattnig <david@subsquare.at>
Date: Mon, 1 Aug 2022 09:32:47 +0200
Subject: [PATCH] chore: add telnet target

---
 Makefile | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index eb16d3b..8c72f46 100644
--- a/Makefile
+++ b/Makefile
@@ -9,9 +9,10 @@ help::
 	@echo "    spell           - check spelling of text"
 	@echo "    test            - run test suite"
 	@echo "    log             - tail log file"
-	@echo "    syslog          - tail syslog file"
+	@echo "    tns             - connect to telnet server"
 	@echo "    run             - start app"
 	@echo "    run.debug       - start app in debug mode"
+	@echo "    docker.init     - create docker volume for engine socket"
 	$(call docker_help)
 
 
@@ -37,6 +38,7 @@ DOCKER_RUN = @docker run \
 		-v "$(AURA_AUDIO_STORE_SOURCE)":"/var/audio/source":ro \
 		-v "$(AURA_AUDIO_STORE_PLAYLIST)":"/var/audio/playlist":ro \
 		-v "$(AURA_AUDIO_STORE_FALLBACK)":"/var/audio/fallback":ro \
+		-p 1234:1234 \
 		-u $(UID):$(GID) \
 		$(DOCKER_ENTRY_POINT) \
 		autoradio/$(APP_NAME)
@@ -62,6 +64,9 @@ test::
 log::
 	tail -f logs/$(APP_NAME).log
 
+tns::
+	telnet 0.0.0.0 1234
+
 run::
 	(cd src && liquidsoap ./engine.liq)
 
-- 
GitLab