diff --git a/setup.py b/setup.py
index 5e4ae1d1ad1251677bf51047a6e529338b014748..2435033ae69eaa6ffccd0e41a405aef40539c3d7 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,22 @@
-# coding: utf-8
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+
 
 import sys
 from setuptools import setup, find_packages
diff --git a/src/base/config.py b/src/base/config.py
index 08ce47b509a7709a81496241e567b654c276e9db..2d90e5cb0a61a46009d02d29a78e8375d4bca72b 100644
--- a/src/base/config.py
+++ b/src/base/config.py
@@ -1,7 +1,7 @@
 #
-# Aura Engine (https://gitlab.servus.at/aura/engine)
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
 #
-# Copyright (C) 2017-2020 - The Aura Engine Team.
+# Copyright (C) 2020 - The Aura Engine Team.
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as published by
diff --git a/src/base/logger.py b/src/base/logger.py
index d1d26730dfece6fa472b8bcec6c818ebea9d3fa3..e0cf95784a0778668ecf3edff41dc202c0273412 100644
--- a/src/base/logger.py
+++ b/src/base/logger.py
@@ -1,7 +1,7 @@
 #
-# Aura Engine (https://gitlab.servus.at/aura/engine)
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
 #
-# Copyright (C) 2017-2020 - The Aura Engine Team.
+# Copyright (C) 2020 - The Aura Engine Team.
 #
 # This program is free software: you can redistribute it and/or modify
 # it under the terms of the GNU Affero General Public License as published by
diff --git a/src/rest/controllers/internal_controller.py b/src/rest/controllers/internal_controller.py
index e2afc419fb670662911674c9593278144aed789d..0bc4630c07ddc752ca1d34d8735bd44c3ff78cef 100644
--- a/src/rest/controllers/internal_controller.py
+++ b/src/rest/controllers/internal_controller.py
@@ -1,3 +1,22 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+
 import connexion
 import six
 
@@ -23,7 +42,7 @@ def get_report(year_month):  # noqa: E501
     """
     return 'do some magic!'
 
-    
+
 def activate_engine(engine_number):  # noqa: E501
     """Set active engine
 
diff --git a/src/rest/controllers/public_controller.py b/src/rest/controllers/public_controller.py
index fc87ff4a3257ed2f2b89e41cef0f0336ea2d30d6..e8e82b4642084f39c4aa48931774298f9e28009e 100644
--- a/src/rest/controllers/public_controller.py
+++ b/src/rest/controllers/public_controller.py
@@ -1,3 +1,22 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+
 import connexion
 import six
 
diff --git a/src/rest/test/test_internal_controller.py b/src/rest/test/test_internal_controller.py
index af0c0e65f9c77c0e3c485d9400abb900aaf4939f..d625f61e7fef3af567e852dee482b45a3646d769 100644
--- a/src/rest/test/test_internal_controller.py
+++ b/src/rest/test/test_internal_controller.py
@@ -1,4 +1,21 @@
-# coding: utf-8
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 from __future__ import absolute_import
 
diff --git a/src/rest/test/test_public_controller.py b/src/rest/test/test_public_controller.py
index 6851f0da55093f91d15bdbcf4b33831c45428ea4..93fee44cd45a93f8b05775b74201a14c697d59c0 100644
--- a/src/rest/test/test_public_controller.py
+++ b/src/rest/test/test_public_controller.py
@@ -1,4 +1,21 @@
-# coding: utf-8
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 from __future__ import absolute_import
 
diff --git a/src/server.py b/src/server.py
index 2a99f1c34686055134493647e2e3f8c2a0223622..79355420659d5621a96046d88c85b11e0aa90cd8 100644
--- a/src/server.py
+++ b/src/server.py
@@ -1,3 +1,21 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 import sys
 import os
diff --git a/src/service/engine_service.py b/src/service/engine_service.py
index 60edff70f09ae6e708aeac0c1f41ba18beffac06..3a578107427f2d583a14f77526c31818177cd2dc 100644
--- a/src/service/engine_service.py
+++ b/src/service/engine_service.py
@@ -1,3 +1,21 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 class EngineService():
 
diff --git a/src/service/playlist_service.py b/src/service/playlist_service.py
index dc4a2eedbf855fff5cb8f9e3d4af6851c7f0fc8c..48a11236de6c95a4d29886b70411512cf55b98d3 100644
--- a/src/service/playlist_service.py
+++ b/src/service/playlist_service.py
@@ -1,3 +1,21 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 class PlaylistService():
 
diff --git a/src/service/track_service.py b/src/service/track_service.py
index a2c4e069d531e062c548c7711cd6f3280fe5caac..861f5bc6cd819137508953f30e108e9b50f13528 100644
--- a/src/service/track_service.py
+++ b/src/service/track_service.py
@@ -1,3 +1,21 @@
+#
+# Aura Engine API (https://gitlab.servus.at/aura/engine-api)
+#
+# Copyright (C) 2020 - The Aura Engine Team.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
 
 class TrackService():