From 56e6c405487091c1b72432678366eda3622cbfc7 Mon Sep 17 00:00:00 2001
From: Chris Pastl <chris@crispybits.app>
Date: Mon, 26 Jun 2023 17:23:38 +0200
Subject: [PATCH] makefile: fix release cmd

---
 Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Makefile b/Makefile
index 26fdc6f..b0f9fdc 100644
--- a/Makefile
+++ b/Makefile
@@ -78,8 +78,8 @@ run.gunicorn::
 	poetry run gunicorn -c config/gunicorn.conf.py aura_engine_api.app:app \
 	--bind $(AURA_ENGINE_API_HOST):$(AURA_ENGINE_API_PORT)
 
-release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
 release::
+	$(eval VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])'))
 	git tag $(VERSION)
 	git push origin $(VERSION)
 	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file
-- 
GitLab