diff --git a/Makefile b/Makefile
index 26fdc6fd287cc3bbbfaa7e1097e03ac056f7155e..b0f9fdc8ccb13931e7bbfde3518f0d0e37f86ffc 100644
--- a/Makefile
+++ b/Makefile
@@ -78,8 +78,8 @@ run.gunicorn::
 	poetry run gunicorn -c config/gunicorn.conf.py aura_engine_api.app:app \
 	--bind $(AURA_ENGINE_API_HOST):$(AURA_ENGINE_API_PORT)
 
-release:: VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])')
 release::
+	$(eval VERSION := $(shell python3 -c 'import tomli; print(tomli.load(open("pyproject.toml", "rb"))["tool"]["poetry"]["version"])'))
 	git tag $(VERSION)
 	git push origin $(VERSION)
 	@echo "Release '$(VERSION)' tagged and pushed successfully."
\ No newline at end of file