package.json 1.03 KB
Newer Older
1
{
2
3
  "name": "dboard",
  "version": "0.1.0",
4
5
  "private": true,
  "scripts": {
6
7
8
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
9
10
  },
  "dependencies": {
11
    "axios": "^0.18.0",
12
13
14
    "bootstrap-vue": "^2.0.0-rc.15",
    "oidc-client": "^1.7.0",
    "vue": "^2.6.10",
15
16
17
    "vue-router": "^3.0.1"
  },
  "devDependencies": {
18
19
20
    "@vue/cli-plugin-babel": "^3.5.1",
    "@vue/cli-plugin-eslint": "^3.5.1",
    "@vue/cli-service": "^3.5.1",
21
    "babel-eslint": "^10.0.1",
22
    "copy-webpack-plugin": "^4.6.0",
23
24
25
    "eslint": "^5.15.3",
    "eslint-plugin-vue": "^5.2.2",
    "vue-template-compiler": "^2.6.10"
26
  },
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
  "eslintConfig": {
    "root": true,
    "env": {
      "node": true
    },
    "extends": [
      "plugin:vue/essential",
      "eslint:recommended"
    ],
    "rules": {},
    "parserOptions": {
      "parser": "babel-eslint"
    }
  },
  "postcss": {
    "plugins": {
      "autoprefixer": {}
    }
45
46
47
48
49
50
51
  },
  "browserslist": [
    "> 1%",
    "last 2 versions",
    "not ie <= 8"
  ]
}