package.json 1.08 KB
Newer Older
1
{
2
3
  "name": "dboard",
  "version": "0.1.0",
4
5
  "private": true,
  "scripts": {
6
7
8
    "serve": "vue-cli-service serve",
    "build": "vue-cli-service build",
    "lint": "vue-cli-service lint"
9
10
  },
  "dependencies": {
11
    "axios": "^0.18.0",
12
    "bootstrap-vue": "^2.0.0-rc.19",
13
    "filesize": "^4.1.2",
14
    "oidc-client": "^1.7.1",
15
    "vue": "^2.6.10",
16
    "vue-router": "^3.0.6"
17
18
  },
  "devDependencies": {
19
20
21
    "@vue/cli-plugin-babel": "^3.6.0",
    "@vue/cli-plugin-eslint": "^3.6.0",
    "@vue/cli-service": "^3.6.0",
22
    "babel-eslint": "^10.0.1",
23
    "copy-webpack-plugin": "^4.6.0",
24
    "eslint": "^5.16.0",
25
26
    "eslint-plugin-vue": "^5.2.2",
    "vue-template-compiler": "^2.6.10"
27
  },
28
29
30
31
32
33
34
35
36
  "eslintConfig": {
    "root": true,
    "env": {
      "node": true
    },
    "extends": [
      "plugin:vue/essential",
      "eslint:recommended"
    ],
37
38
39
    "rules": {
      "no-console": "off"
    },
40
41
42
43
44
45
46
47
    "parserOptions": {
      "parser": "babel-eslint"
    }
  },
  "postcss": {
    "plugins": {
      "autoprefixer": {}
    }
48
49
50
51
52
53
54
  },
  "browserslist": [
    "> 1%",
    "last 2 versions",
    "not ie <= 8"
  ]
}